phpMyAdmin blowfish secret generator

The configuration file now needs a secret passphrase (blowfish_secret).
You’ll see this error after every installation of phpmyadmin.
To resolve this issue, just open config.inc.php ( or rename config.sample.inc.php to config.inc.php if you haven’t done so yet ) and change this line

$cfg['blowfish_secret'] = ''; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

to

$cfg['blowfish_secret'] = 'iEYwB:[;Y8-hMuT0lz3Qc/0DMDpSK1}5';

To generate new blowfish secret, simply hit this https://phpsolved.com/phpmyadmin-blowfish-secret-generator/?g=5d2f970d98cf1

Write a Comment

Comment

  1. Sometimes your random blowfish_secret ends with \
    That will result in an error since php will read the last \ as an escape code.
    Just take the \ away from the available random chars and you’re fine.